Others Seneca Aspen Fixed!

Ronno6

Active member
27
43
HAM Points
193.25
Country flag
I picked up an "untested: Seneca Aspen off the bay.
Of course, it leaked out the barrel.
I ordered an exhaust valve poppet from PA, but it was different than the original and didn't cure the leak anyway.

Next link in the chain was the exhaust valve sleeve.
After chatting with AV, they sent me a new sleeve and stem.

NO MO LEAK.........

The barrel is losing air when fired where it enters the receiver, so new O-rings are en route.

Then the pump arm got REAL stiff...........just needed some silicone oil.
It pumps, it shoots, it holds air!

So, it will shortly be good to go..........where, exactly, I no not as yet........
 
I am waiting for a fill probe to precharge the "balance" chamber.......something I just learned about...
I guess it makes pumping easier ?? Interesting stuff......
 
Well, only partially fixed..........
There is this little tube under the barrel called a "balancer tube." Its function, I guess, is to provide some sort of assist when hand pumping against a pressurized main reservoir. i replaced all the O-rings except 1...the ball check valve O-ring. TRY to find that little bugger.....ANYWHERE.... i put in a call to Air Venturi and was told that they use a different size.....WAY too small... So, I'm waiting for more O-rings now.
 
I more or less finally got the balancer tube sealed and pre-charged...that required a special probe.
Assembled and aired it up.
All went well....for a while.
Apparently the pump check valves needed their O-rings replaced, as air would leak back into BOTH sides of the pump. After pressurizing the main reservoir to 3000psi, it would leak back into the bump, dropping the pressure down to 2200psi, where it would stay. However the pump arm would be almost impossible to open, and, once opened, it would open half way, and be impossible to move either way from there.........either open or close...
So, tiring from this exercise, I listed on the bay and sold it as is.........hopefully the buyer can figure it out....
I'm DONE..............
 
I more or less finally got the balancer tube sealed and pre-charged...that required a special probe.
Assembled and aired it up.
All went well....for a while.
Apparently the pump check valves needed their O-rings replaced, as air would leak back into BOTH sides of the pump. After pressurizing the main reservoir to 3000psi, it would leak back into the bump, dropping the pressure down to 2200psi, where it would stay. However the pump arm would be almost impossible to open, and, once opened, it would open half way, and be impossible to move either way from there.........either open or close...
So, tiring from this exercise, I listed on the bay and sold it as is.........hopefully the buyer can figure it out....
I'm DONE..............
Ya, but your so much more experienced now .. that equals a lot next time.😉
 

Create an account or login to comment

You must be a member in order to leave a comment

Create FREE account

Create a FREE account on our community. It's easy!

Log in

Already have an account? Log in here.

Back
Top